Announcements & Release Notes

ELIS 2.6.1.0 Released

 
 
Picture of Brent Boghosian
ELIS 2.6.1.0 Released
by Brent Boghosian - Monday, 10 March 2014, 1:19 PM
 
Remote-Learner is pleased to announce ELIS 2.6.1.0. This release is based on Moodle 2.6.2 and contains ELIS as standard Moodle plugins.
 

Notices

  • ELIS 2.6.1.0 requires Moodle 2.6.2 or greater.
  • ELIS Core & Program components are now local plugins, the scripts directories are now located in local/eliscore/scripts and local/elisprogram/scripts respectively.
  • The DataHub component is now a local plugin and no longer a block - existing DataHub blocks are automatically converted to HTML blocks during install/upgrade.
  • DataHub import and export directories will use the settings of the old plugin, if present. Otherwise, it will use the new default dataroot import & export directories.
  • DataHub WebServices had to be renamed to conform to new plugin type, any existing code using the old webservices will have to be updated to call the new functions.

ELIS Core 2.6.1.0 (local_eliscore)


Bug

  • ELIS-8713 - Strict standards warnings on pm class detail page

Story

  • ELIS-8612 - Determine some possible options for replacing core Moodle changes in install/upgrade to support elis scheduled tasks .../db/tasks.php component files
  • ELIS-8630 - Move ELIS core to local plugin migrating cron also
  • ELIS-8633 - Remove ELIS custom contexts core hacks and re-implement to use auto-loaders, etc.
  • ELIS-8643 - Build rlmoodle.plain.git MOODLE_26_STABLE
  • ELIS-8671 - Update calls to fullname()
  • ELIS-8673 - Create Moodle tracker issue for required changes to support custom contexts (MDL-43635)
  • ELIS-8702 - Fix notices during eliscore install

ELIS Program 2.6.1.0 (local_elisprogram)


Bug

  • ELIS-8707 - Custom fields are not visible in detail page for an ELIS User and User Set
  • ELIS-8713 - Strict standards warnings on pm class detail page
  • ELIS-8715 - Deprecated warnings in some ELIS course tab pages

Improvement

  • ELIS-8665 - Determine whether we still need table crlm_config(local_elisprogram_config) and remove if not.
  • ELIS-8666 - Determine if we're still using crlm_usercluster(local_elisprogram_usr_uset) and remove if not.
  • ELIS-8667 - Determine what we still need from the elis_program pix directory and delete everything else

Story

  • ELIS-8629 - Create classes extending backup_plan_builder & restore_plan_builder with public static build_course_plan() methods
  • ELIS-8631 - Move elis/program to local/elisprogram
  • ELIS-8633 - Remove ELIS custom contexts core hacks and re-implement to use auto-loaders, etc.
  • ELIS-8635 - Remove PARAM_RAW variable sanitisation code where possible
  • ELIS-8671 - Update calls to fullname()
  • ELIS-8685 - Add mechanism on ELIS admin dashboard (i.e. details/components link) to display all ELIS components version & release info

ELIS Reports 2.6.1.0 (local_elisreports)


Bug

  • ELIS-8709 - Emails not being sent by ELIS Reports

Story

  • ELIS-8634 - Move block/php_report to local/elisreports
  • ELIS-8671 - Update calls to fullname()

ELIS Administration 2.6.1.0 (block_elisadmin)


Story

  • ELIS-8680 - Rename component block_curr_admin to block_elisadmin
  • ELIS-8701 - Fix incorrect language strings in block_elisadmin

Enrol ELIS 2.6.1.0 (enrol_elis)


Bug

  • ELIS-8714 - Deprecated warnings in ELIS enrol plugin

DataHub 2.6.1.0 (local_datahub)


Bug

  • ELIS-8705 - DataHub dhimport plugins shown as 'missing from disk' on Plugins Overview page

Story

  • ELIS-8632 - Move blocks/rlip to local/datahub
  • ELIS-8671 - Update calls to fullname()

Block CourseRequest 2.6.1.0 (block_courserequest)


Story

  • ELIS-8681 - Rename component block_course_request to block_courserequest

Block EnrolSurvey 2.6.1.0 (block_enrolsurvey)


Story

  • ELIS-8682 - Rename component block_enrol_survey to block_enrolsurvey